Alguns PPAs

 
Introdução

PPA, de Personal Packages Archives, são repositórios mantif=dos, na maior parte das vezes, por desenvolvedores, e trazem as versões mais novas dos programas, que ainda não atingiram os repositórios oficias do Ubuntu.

É possível utilizar as versões de programas dos PPAs para ter acesso às últimas funcionalidades que os desenvolvedores estão adicionando aos programas, com ênfase em "estão adicionando", pois se tratam de versões em desenvolvimento, mais suscetíveis a bugs que as versões estáveis dos repositórios oficiais.

Outro aspecto que deve ser considerado antes de se adotar cegamente os PPAs, é que eles podem estar utilizando versões mais novas de bibliotecas compartilhadas por outros programas, e isso pode ocasionar a quebra desses outros programas.

Trata-se, portanto, de uma aposta: será que as novas funcionalidades compensam o risco de se desestabilizar o sistema?

Se a sua é u'a máquina de produção, apenas instale os PPAs de programas para os quais você realmente necessite das novas funcionalidades. Se for sua máquina pessoal, seja mais ousado.

Este artigo traz uma compilação de PPAs que aparecem em tutoriais do Guicolandia, assim como alguns outros, coletados alhures.

Lembre-se que todos os comandos devem ser rodados no Terminal (Ctrl+AlT):
Nautilus:

sudo add-apt-repository ppa:gnome3-team/gnome3

sudo apt update

sudo apt full-upgrade

Thunderbird:

sudo add-apt-repository ppa:mozillateam/thunderbird-next

sudo apt update

sudo apt upgrade

Wine:


sudo add-apt-repository ppa:ubuntu-wine/ppa


sudo apt update


sudo apt install wine winetricks

LibreOffice:

Antes de atualizar o LibreOffice para a versão do PPA, recomenda-se eliminar a versão presente completamente:


sudo apt-get remove --purge libreoffice*


sudo apt clean


sudo apt autoremove


Após ter completamente desinstalado o LibreOffice, hora de incluir seu PPA e instalar a versão de desenvolvimento (com o tema Breeze):


sudo add-apt-repository ppa:libreoffice/ppa


sudo apt update


sudo apt install -y libreoffice libreoffice-style-breeze


sudo apt install libreoffice-l10n-pt-br

Multisystem:


sudo apt-add-repository 'deb http://liveusb.info/multisystem/depot all main'


wget -q -O - http://liveusb.info/multisystem/depot/multisystem.asc | sudo apt-key add -


sudo apt update


sudo apt install -y multisystem

Atom:


sudo add-apt-repository ppa:webupd8team/atom


sudo apt update


sudo apt install atom

Brightness Contol:


sudo add-apt-repository ppa:apandada1/brightness-controller


sudo apt update


sudo apt install brightness-controller

Telegram:


sudo add-apt-repository ppa:atareao/telegram


sudo apt update


sudo apt install telegram-desktop

 

GIMP:


sudo add-apt-repository ppa:otto-kesselgulasch/gimp


sudo apt update


sudo apt install -y gimp gimp-gmic


sudo apt install icc-profiles icc-profiles-free


Atenção: as últimas versões do GIMP têm provocado incompatibilidadescom o pacote do Plugin Registry, porque a central de plugins está sem mantenedor do código. Isso é especialmente problemático para quem quer usar o Separate+. Por isso, separei esta parte do código. Instale o GIMP e o G'Mic e tente instalar o Registry posteriormente.


sudo apt install -y gimp-plugin-registry

Krita:


sudo add-apt-repository ppa:dimula73/krita


sudo apt update


Para a versão de testes, mais propensa a erros, rode o comando abaixo:


sudo apt install krita3-testing


Para a versão estável, instale:


sudo apt krita

Scribus:


sudo add-apt-repository ppa:scribus/ppa

Scribus:


sudo add-apt-repository ppa:scribus/ppa


sudo apt update


Para a versão estável, digite:


sudo apt install scribus


Para a versão NG, altamente recomendável, rode o comando abaixo:


sudo apt install scribus-ng


Para a versão de testes, com compilação diária, extremamente propensa a bugs e, portanto, não recomendada, rode o seguinte comando:


sudo apt install scribus-trunk

KDEnlive:


sudo add-apt-repository ppa:kdenlive/kdenlive-stable


sudo apt update


sudo apt install kdenlive


OpenShot:


sudo add-apt-repository pppa:haraldhv/shotcut


sudo apt update


sudo apt install libsdl2-2.0 shotcut

OBS - Open Broadcasting System:


sudo add-apt-repository ppa:obsproject/obs-studio


sudo apt update


sudo apt install obs-studio












Para apagar um PPA:


sudo add-apt-repository ppa:<nome do ppa> --remove


sudo apt update